#1 2022-06-09 03:15:21

Registered: 2022-05-30

JXLS Report Parameters - Date parameters not working in SQL queries

Issue: For some reason, when I use the Date parameter in ReportServer for my JXLS reports, the SQL query does not return any results.

What I've tried:

a. Creating the report by exporting a JXLS template from a Dynamic List report and then modifying the template into a JXLS report
b. Duplicating existing JXLS templates which are currently working and then making the necessary changes
c. Following the GitHub examples: https://github.com/infofabrik/reportser … meter.xlsx

I am not sure if I am accessing the parameters from inside the SQL query correctly.

In the GitHub parameters example, the syntax used is (`${parameterKey}`)

Alternatively, I understand according to the documentation (https://reportserver.net/en/guides/admi … S-Reports/) that another method is to do (`${parameters.parameterKey}`).

I understand this could just be different ways of accessing parameters (https://reportserver.net/en/guides/admi … arameters/), but nonetheless both versions have not worked for me.

I have tried changing and using different parameter keys and names, but that has not worked so far either.

Additionally, I noticed that my reports that use the Datasource parameter type do return the correct results for the corresponding SQL queries. However, I doubt the parameter type is the cause of the issue here.

May I clarify how exactly I should build the JXLS template with parameters in the SQL query? Thanks in advance!

Last edited by Johann (2022-06-09 03:31:35)


#2 2022-06-09 08:37:26

Registered: 2016-11-01

Re: JXLS Report Parameters - Date parameters not working in SQL queries

Hi Johann,

is the github parameters example working in your case ? If not, what happens? if yes -> what is different in your not-working example? can you then modify the github example in such a way, that as your example it doesn't work?



#3 2022-06-09 09:26:19

Registered: 2022-05-30

Re: JXLS Report Parameters - Date parameters not working in SQL queries

Yes, the github parameters example works. The only difference I can tell is the parameter type.

In the example, a text parameter is used, and in my own working examples I use the Datasource type.

The issue arises when I use the Date parameter type. If there were an error in my query, would there be any logs or way to tell what went wrong? Currently, if the query were not valid or had syntax errors, I think there will just be no rows generated, which makes it a little difficult to debug.


Board footer

Powered by FluxBB