#1 2015-02-09 14:47:26

Registered: 2015-02-09

Pivot reports on PostgreSql

I recently installed ReportServer on Ubuntu machine, using Apcache Tomcat as webserver.

In ReportManager I create simple Dinamic List report using PostgreSQL Data Source with integer parameter (select * from dummy_table where dummy_id = ${key1})
Then I import this report in Teamspace and everyting works fine, parameter is there and data is displayed as well. But when I activate pivoting mode, chose some fields then i see error  "PSQLException: ERROR: invalid input syntax for type numeric: "" Position: 117"
If I not use parameters then pivoting works perfectly
If I create following manipalation with parameter in query also works perfectly select * from dummy_table where dummy_id  =  CAST(('0' || COALESCE( ${key1} ,'0')) AS INTEGER)
this manipulation is not working on date parameters though

I tried exactly the same report using MySQL Data Source - everything works as expected.
I tried also several versions of Postgre JDBC drivers not helped

My PostgresSQL DB version 9.3.5
My RS version: RS2.2.1-5602 2014-12-17-20-23-49

Will be very pleased with any help, Thanks in advance!


#2 2015-02-12 16:30:15

Thorsten J. Krause
Registered: 2012-02-15

Re: Pivot reports on PostgreSql


Thank you for reporting this! There was an error in the code passing parameter values to the database when using pivot on dynamic lists. I fixed it in the development branch and this will be included in the next bugfix release.

Customers with a maintenance contract, that require an immediate fix, please open a ticket in the support system.



#3 2015-02-27 13:39:11

Registered: 2015-02-26

Re: Pivot reports on PostgreSql

I hit this bug as well and after a while I realized I should not be using parameters in pivots.
Also, mondrian throws exceptions when the datasource is actually a datasource bundle. You may want to fix that too.


Board footer

Powered by FluxBB