#1 2022-07-20 09:36:48

Johann
Member
Registered: 2022-05-30

Possible contradiction in required JRE version for ReportServer

In https://reportserver.net/en/guides/conf … tallation/, it is stated:

ReportServer requires an installed Java Runtime Environment (JRE) in version 11 or newer.

whereas in https://reportserver.net/en/tutorials/i … t-practice, it is stated:

A detailed installation of how to install Oracle Java 8 can be found, for example, o http://www.webupd8.org/2012/09/install- … a-ppa.html.


Would Java 8 be sufficient, or is it required to upgrade to Java 11 if we are currently using Java 8? Thank you in advance!

Offline

#2 2022-07-20 11:21:20

eduardo
Administrator
Registered: 2016-11-01
Website

Re: Possible contradiction in required JRE version for ReportServer

Hi Johann,

for newer versions of ReportServer Java 11 is needed. The https://reportserver.net/en/tutorials/i … -practice/ tutorial is outdated and we are working on updating it.

Regards,
Eduardo

Offline

#3 2022-07-20 15:17:23

Johann
Member
Registered: 2022-05-30

Re: Possible contradiction in required JRE version for ReportServer

Hi Eduardo,

Thank you for confirming!

Regards,
Johann

Offline

#4 2022-07-21 01:14:30

Johann
Member
Registered: 2022-05-30

Re: Possible contradiction in required JRE version for ReportServer

Hi Eduardo,

May I confirm that the statement from https://reportserver.net/blog/2018/10/3 … sing-2019/

If they decide not to buy LTS support, they may still stay on the latest Java 8 version, eventually on a properly secured Intranet

is no longer valid at this time? In other words, users have to upgrade from Java 8 to Java 11 to use the newer versions of ReportServer. Thank you!

Offline

#5 2022-07-21 04:43:02

Johann
Member
Registered: 2022-05-30

Re: Possible contradiction in required JRE version for ReportServer

Hi Eduardo,

May I also check regarding the additional JRE options to set when using Java 11 (https://reportserver.net/en/guides/conf … tallation/):

Creating the `setenv.sh` file results in Tomcat failing to start with the following error message:

Job for tomcat.service failed because the control process exited with error code. See "systemctl status tomcat.service" and "journalctl -xe" for details.


These are the contents of the Tomcat `setenv.sh` file (on Linux):

 set JAVA_OPTS=++JvmOptions="--add-opens=java.base/java.net=ALL-UNNAMED" ++JvmOptions="add-opens=java.base/jdk.internal.ref=ALL-UNNAMED" ++JvmOptions="--ad-opens=java.base/jdk.internal.reflect=ALL-UNNAMED" ++JvmOptions="-D.javax.net.ssl.trustStoreType=JKS"

The options and values are copied from the documentation and the syntax for setting the configuration is copied from the example configuration provided. Is there something wrong with this configuration?

Thank you!
Regards,
Johann

Last edited by Johann (2022-07-21 04:43:34)

Offline

#6 2022-10-18 11:33:35

eduardo
Administrator
Registered: 2016-11-01
Website

Re: Possible contradiction in required JRE version for ReportServer

eduardo wrote:

for newer versions of ReportServer Java 11 is needed. The https://reportserver.net/en/tutorials/i … -practice/ tutorial is outdated and we are working on updating it.


Hi Johann,

pls note we updated the Linux best-practice installation guide: https://reportserver.net/en/tutorials/i … -practice/
We are currently working on the Windows guide and will update here when it is available.

Regards,
Eduardo

Offline

Board footer

Powered by FluxBB