#1 2018-07-23 13:49:38

pmace
Member
Registered: 2016-10-07
Posts: 18

Date/Time parameters are always seen as Text Parameters

Hi,

i updated my reportserver version from 3.0.2 to 3.0.3 and i'm facing issues :
I imported Birt design templates with Date/Time parameters, but i set such parameters in report parameters and run the report, i have an error saying that these paramerters are expecting String instead of java.Date format.

However, after downloading the birt design template, i could see that in the template, these parameters are java.date ones ...
It seems that the new version of reportserver is badly interpreting the format of date parameters.

What could I do ?

Additionnaly, in the previous version, after doing "extract parameters", Reportserver left blank the type of these parameters. Now, it automatically set them as Text parameters.
Template was done with Eclipse Neon Release (4.6.0).

Thanks in advance

Offline

#2 2018-07-23 14:34:34

eduardo
Administrator
Registered: 2016-11-01
Posts: 759

Re: Date/Time parameters are always seen as Text Parameters

Hi pmace,

you can always change the parameters in the "parameters" tab of the report. Why don't you set them there / modify them if they are incorrect?

Can you please post a *minimal* birt report that reproduces this issue? I also need your exact reportserver version (rsversion.properties). Some screenshots showing the behavior would also help, you can post them here: http://www.imgbb.com

Regards,
Eduardo

Offline

#3 2018-07-27 07:58:31

pmace
Member
Registered: 2016-10-07
Posts: 18

Re: Date/Time parameters are always seen as Text Parameters

Hi eduardo,

sorry for my late answer, i forgot to subscribe to notification for my post.
I forgot to mention this point : even after changing the parameter type to Date parameter, i still have an error saying that the expected type is a date and not a string.

The content of rsversion.properties is :
cat /var/lib/tomcat7/webapps/ROOT/WEB-INF/classes/rsversion.properties
#
#Tue Jun 26 15:44:11 CEST 2018
version=RS3.0.3-6003
schemaversion=RS3.0-9
buildDate=1530020651312-2018-06-26-15-44-00

You can download via the below link a report with which one i reproduce the issue and its associated birt library from which one the used parameters are extracted. Into the archive, there are also screenshots of the RS error.
https://wetransfer.com/downloads/475b64 … ient_email

The environment into which one the issue is reproduced is a server with a 3.0.2 version previously installed with these reports alredy configured and an upgrade to 3.0.3 was performed.

Thanks for your support.

Br,

Offline

#4 2018-09-03 15:46:18

pmace
Member
Registered: 2016-10-07
Posts: 18

Re: Date/Time parameters are always seen as Text Parameters

Hi Eduardo,

could you give me any feedback on my previous answer please ?

We are blocked to upgrade reportserver version until this behaviour is fixed.

Thanks in advance

Br,
Pierre Macé

Offline

#5 2018-09-25 07:18:01

eduardo
Administrator
Registered: 2016-11-01
Posts: 759

Re: Date/Time parameters are always seen as Text Parameters

Hi pmace,

the link you posted is not working, could you please double check this ?

Regards,
Eduardo

Offline

#6 2018-09-25 07:45:12

pmace
Member
Registered: 2016-10-07
Posts: 18

Re: Date/Time parameters are always seen as Text Parameters

Hi,

i reuploaded the files mentionned.

https://wetransfer.com/downloads/5383bd … 246/b40cef

Br,

Offline

#7 2018-09-25 07:58:08

eduardo
Administrator
Registered: 2016-11-01
Posts: 759

Re: Date/Time parameters are always seen as Text Parameters

Hi pmace,

"and its associated birt library from which one the used parameters are extracted" --> What do you mean exactly by this ? I don't quite understand this.

I also saw that the example you posted is not minimal. Please delete everything unnecessary in order to remove other sources of problems. The best would be in this case to remove everything else and just print the values of the two parameters you mention in the report. Since we are only talking about the problems with the parameters, this should be enough to reproduce the problem.

Regards,
Eduardo

Offline

Board footer

Powered by FluxBB