#1 2019-02-13 10:45:25

allengu
Member
Registered: 2018-09-07
Posts: 7

Question about schema definition of Mondrian Datasource

Hello,

I have a question about Japanese characters in schema definition of Mondrian Datasource.
The Japanese characters are not shown correctly when using EE version,  but CE version is OK.

ENV info:
ReportServer 3.0.5

I hope you can help me, Thanx.

ScreenShot1(in EE version)
EE version

ScreenShot2(in CE version)
CE version

The following codes are a part of my schema definition.

<?xml version='1.0'?>
<Schema name="BI" metamodelVersion='4.0'>
    <PhysicalSchema>
        <Table name='pl_fact'/>
        <Table name='productlevel'>
            <Key>
                <Column name='LEVEL_ID'/>
            </Key>
        </Table>
        <Table name='plitem'>
            <Key>
                <Column name='ITEM_CD'/>
            </Key>
        </Table>
        <Table name='ym'>
            <Key>
                <Column name='YM_ID'/>
            </Key>
        </Table>
        <Table name='product'>
            <Key>
                <Column name='M_ITEM_CD'/>
            </Key>
        </Table>
        <Table name='customer'>
            <Key>
                <Column name='CUSTOMER_CD'/>
            </Key>
        </Table>
        <Table name='agg_lc_area1_level4_pl_fact'/>
        <Table name='agg_lc_area2_level4_pl_fact'/>
    </PhysicalSchema>
    
    <Dimension name='区域' table='customer' key='Customer Cd'>
        <Attributes>
            <Attribute name='大大区' hasHierarchy='false'>
                <Key>
                    <Column name='AREA1'/>
                </Key>
                <OrderBy>
                    <Column name='AREA1'/>
                </OrderBy>
            </Attribute>
            <Attribute name='大区' hasHierarchy='false'>
                <Key>
                    <Column name='AREA1'/>
                    <Column name='AREA2'/>
                </Key>
                <Name>
                    <Column name='AREA2'/>
                </Name>
                <Caption>
                    <Column name='AREA2'/>
                </Caption>
                <OrderBy>
                    <Column name='AREA2'/>
                </OrderBy>
            </Attribute>
            <Attribute name='区域' hasHierarchy='false'>
                <Key>
                    <Column name='AREA1'/>
                    <Column name='AREA2'/>
                    <Column name='AREA3'/>
                </Key>

Last edited by allengu (2019-02-13 10:54:51)

Offline

#2 2019-02-13 11:04:27

eduardo
Administrator
Registered: 2016-11-01
Posts: 1,011
Website

Re: Question about schema definition of Mondrian Datasource

Hi allengu,

both installations are made in different tomcat instances, is this correct? Or in different machines? At least they use different internal databases, since one is CE and the other is EE. Maybe the database UTF-8 settings are different in the databases, or the settings are different in both installations? this could also be caused by the database encoding, or the encoding of the database connection. Check that all settings in both installations are exact.

Regards,
Eduardo

Offline

Board footer

Powered by FluxBB