#1 2017-07-11 07:18:55

Achilie
Member
From: Hamburg, Deutschland
Registered: 2017-01-24
Posts: 35
Website

JDBC-Connection

Hi @All,

I have downloaded the latest Beta RS-3.0.3-beta-20170710 an installed it over a Bitnami-Installation as described.
In this Installation i have configured an Oracle-Datsource which was working.
Now i am facing the following error:
500 Internal Server Error The call failed on the server; see server log for details Statuscode:
500 EncodedResponse: The call failed on the server; see server log for details

I am unable to find this Error-Log.
Please can you direct me to find the Error in the Log-File.

Thanks
Joachim

Offline

#2 2017-07-11 08:11:49

edulid
Administrator
Registered: 2016-11-01
Posts: 367

Re: JDBC-Connection

Hi Achilie,

Achilie wrote:

In this Installation i have configured an Oracle-Datsource which was working.
Now i am facing the following error:
500 Internal Server Error The call failed on the server; see server log for details Statuscode:
500 EncodedResponse: The call failed on the server; see server log for details

What exactly do you do before getting this error? are you opening a report? or are you testing the connection?

Achilie wrote:

I am unable to find this Error-Log.
Please can you direct me to find the Error in the Log-File.

The tomcat logs are found in the bitnami installation here:
C:\Bitnami\reportserverenterprise-3.0.2-6\apache-tomcat\logs
The first thing I would do is to stop reportserver (apache, tomcat and reportserver), then archive all existing logs, then delete all logs in this directory, and start reportserver again. So you can see exactly what happens during your testing actions.

Furthermore, I would first test the connection. Please go to your datasources, then click on "test connection". This is the first thing that has to work. If this connection test doesn't work, check your logs and please post the complete error stack here.

Best regards,
Eduardo

Offline

#3 2017-07-11 11:03:42

Achilie
Member
From: Hamburg, Deutschland
Registered: 2017-01-24
Posts: 35
Website

Re: JDBC-Connection

Hi Eduardo,

this happened when i hit the Test Connection Button in the Datasource Panel.
There are no Error in the Log-Files.
The last Line (in reportserverenterprisetomcat-stderr.2017-07-11.log) is something like:
11-Jul-2017 10:59:43.665 INFO [main] org.apache.catalina.startup.Catalina.start Server startup in 61709 ms.

Joachim

Offline

#4 2017-07-11 11:52:19

edulid
Administrator
Registered: 2016-11-01
Posts: 367

Re: JDBC-Connection

Hi Joachim,

this is strange. Did you check also the other logs ? (not only stderr)

Important: did you add your oracle drivers to your WEB-INF/lib directory ? you added these maybe in 3.0.2, but these are not included in 3.0.3-beta. Could you please check this ?

Regards,
Eduardo

Offline

#5 2017-07-11 12:58:11

Achilie
Member
From: Hamburg, Deutschland
Registered: 2017-01-24
Posts: 35
Website

Re: JDBC-Connection

Hi Eduardo,

the driver is added.
There is no Log written.
One strange thing:
When we try to connect with a locked User we get this error. (User is locked). This is a response from Oracle.
I unlocked the user and i get the error 500.
Btw. the error with a locked user is not reported in the Log-Files.

I have a local Postgres and there is no problem to connect to this database.

I will try with a fresh installation from Bitnami, maybe sonthing was overwritten.

Joachim

Offline

#6 2017-07-11 13:46:53

Achilie
Member
From: Hamburg, Deutschland
Registered: 2017-01-24
Posts: 35
Website

Re: JDBC-Connection

I checked it with a fresh installation:
RS3.0.2-5855
2016-05-29-17-55-24
Enterprise Edition (Evaluation)

I created an Oracle-DB connection and it worked fine:
jdbc:oracle:thin:@10.65.3.91:1521/vhgsqa

After upgrading the connection throws the error.
No log file shows the error.
(reportserverenterprisetomcat-stderr.2017-07-11.log, catalina.2017-07-11.log, localhost_access_log.2017-07-11.txt, commons-daemon.2017-07-11.log, reportserverenterprisetomcat-stdout.2017-07-11.log)

Offline

#7 2017-07-11 14:34:20

edulid
Administrator
Registered: 2016-11-01
Posts: 367

Re: JDBC-Connection

Hi Joachim,

I sent you an email for further testing, please check if you got it.

Best regards,
Eduardo

Offline

#8 2017-07-13 09:57:46

edulid
Administrator
Registered: 2016-11-01
Posts: 367

Re: JDBC-Connection

Hello all,

for completeness: to use 3.0.3-beta with Oracle, the following jars (or newer versions) are needed: ojdbc6.jar, orai18n.jar, xdb6.jar and xmlparserv2.jar. These are needed because of the new XML/JSON support. Please copy them to the WEB-INF/lib directory.

This was the source of the problem here.

Best regards,
Eduardo

Offline

Board footer

Powered by FluxBB