#1 2017-11-16 11:45:44

xpirito
Member
Registered: 2017-11-16
Posts: 12

ReportServer 3.0.2.8 - IE report dadget HTML render issues

Hello.

I'm experiencing a strange issue with ReportServer Community Edition, as it seems to miss something (maybe dependencies?) and doesn't render any graph in report dadget HTML mode on dashboards.

Here is an example of the screen:

1pxkp5.jpg

Could anynone help me solve this issue? Thanks a lot for your help!

Last edited by xpirito (2017-11-16 12:12:20)

Offline

#2 2017-11-16 11:56:00

eduardo
Administrator
Registered: 2016-11-01
Posts: 1,080
Website

Re: ReportServer 3.0.2.8 - IE report dadget HTML render issues

Hi xpirito,

is this working on other browsers ?

Regards,
Eduardo

Offline

#3 2017-11-16 11:59:39

xpirito
Member
Registered: 2017-11-16
Posts: 12

Re: ReportServer 3.0.2.8 - IE report dadget HTML render issues

Yes, it seems to work good using Chrome. I'm not able to use Chrome in end-user workstations, though.

Offline

#4 2017-11-16 11:59:45

eduardo
Administrator
Registered: 2016-11-01
Posts: 1,080
Website

Re: ReportServer 3.0.2.8 - IE report dadget HTML render issues

And what type of dadget are you using? HTML ? Or saiku? What exactly do you mean by "graph"?

Regards,
Eduardo

Offline

#5 2017-11-16 12:03:22

xpirito
Member
Registered: 2017-11-16
Posts: 12

Re: ReportServer 3.0.2.8 - IE report dadget HTML render issues

I'm selecting "HTML" mode dadget's format view:

GWXdMcN.jpg

Offline

#6 2017-11-16 12:08:34

eduardo
Administrator
Registered: 2016-11-01
Posts: 1,080
Website

Re: ReportServer 3.0.2.8 - IE report dadget HTML render issues

Ok, so you are using a "report dadget" with the HTML format, correct?
What kind of report is the report "UCI - Admissoes Dashboard"?

Regards,
Eduardo

Offline

#7 2017-11-16 12:11:04

xpirito
Member
Registered: 2017-11-16
Posts: 12

Re: ReportServer 3.0.2.8 - IE report dadget HTML render issues

Yes, report dadget with HTML format.

This report "UCI - Admissoes Dashboard" was made using BIRT on Eclipse Neon.

Offline

#8 2017-11-16 12:22:19

eduardo
Administrator
Registered: 2016-11-01
Posts: 1,080
Website

Re: ReportServer 3.0.2.8 - IE report dadget HTML render issues

Which IE version are you using? I tried with IE 11 and it worked. I did the following:

1. New dadget, type: Report
2. Select report: TopNCustomers
3. Format: HTML

For this, you have to have the demo data installed. For installing: https://reportserver.net/en/guides/conf … Demo-Data/
Please install in a test system since the demo data deletes all previous data in the system.

Could you please try with this report ? For me, it worked.

Regards,
Eduardo

Offline

#9 2017-11-16 12:34:01

xpirito
Member
Registered: 2017-11-16
Posts: 12

Re: ReportServer 3.0.2.8 - IE report dadget HTML render issues

I'm using IE11 to render this, running in IE9 compatibility mode.

Offline

#10 2017-11-16 13:33:43

eduardo
Administrator
Registered: 2016-11-01
Posts: 1,080
Website

Re: ReportServer 3.0.2.8 - IE report dadget HTML render issues

ok, and does it work *without* the IE9 compatibility mode ?

Regards,
Eduardo

Offline

#11 2017-11-16 15:03:07

xpirito
Member
Registered: 2017-11-16
Posts: 12

Re: ReportServer 3.0.2.8 - IE report dadget HTML render issues

edulid wrote:

ok, and does it work *without* the IE9 compatibility mode ?

Regards,
Eduardo

No, without it we get javascript errors (see other topic I've also opened about that specific issue).

Offline

#12 2017-11-16 15:09:49

eduardo
Administrator
Registered: 2016-11-01
Posts: 1,080
Website

Re: ReportServer 3.0.2.8 - IE report dadget HTML render issues

Hi xpirito,

so if I understand correctly, all charts in your birt reports *NEVER* are shown in Internet Explorer 11, correct ?

Regards,
Eduardo

Offline

#13 2017-11-16 15:15:23

xpirito
Member
Registered: 2017-11-16
Posts: 12

Re: ReportServer 3.0.2.8 - IE report dadget HTML render issues

Yes, correct. All of them always show an error when I try to render using IE11 native mode. When I use "Compatibility Mode" to IE9 I get this strange behavior where these icons are shown instead of expected report output.

Offline

#14 2017-11-16 16:45:06

xpirito
Member
Registered: 2017-11-16
Posts: 12

Re: ReportServer 3.0.2.8 - IE report dadget HTML render issues

Tried Firefox Portable, seems to render as expected using that browser. Any thoughts?

oIMH3uW.jpg

Offline

#15 2017-11-20 15:37:24

xpirito
Member
Registered: 2017-11-16
Posts: 12

Re: ReportServer 3.0.2.8 - IE report dadget HTML render issues

Any news on this? Can anybody help?

Offline

#16 2017-11-23 14:34:44

eduardo
Administrator
Registered: 2016-11-01
Posts: 1,080
Website

Re: ReportServer 3.0.2.8 - IE report dadget HTML render issues

Hi xpirito,

sorry for the delay. We are doing some testing. As soon as I have more information I will post it here.

Regards,
Eduardo

Offline

#17 2017-11-23 14:48:16

eduardo
Administrator
Registered: 2016-11-01
Posts: 1,080
Website

Re: ReportServer 3.0.2.8 - IE report dadget HTML render issues

Hi xpirito,

you are right, the HTML export of charts in BIRT reports is not working with Edge / Internet Explorer. We will take a look at this. I created RS-2799 for this purpose.

On the meanwhile, why don't you select "View Format":  "Complete Standard View" instead of "HTML"? This creates the standard pdf, which is shown in all browsers without any issue.

Regards,
Eduardo

Offline

#18 2017-11-29 15:24:23

xpirito
Member
Registered: 2017-11-16
Posts: 12

Re: ReportServer 3.0.2.8 - IE report dadget HTML render issues

Hello. Thank you very much for this update.

Do you know if there are any plans on releasing an hotfix for this?

Thanks for your support.

Kind regards

Offline

#19 2017-12-07 10:29:14

eduardo
Administrator
Registered: 2016-11-01
Posts: 1,080
Website

Re: ReportServer 3.0.2.8 - IE report dadget HTML render issues

Hi xpirito,

we will take a look at this. Depending on the changes needed, this will be fixed either in a patch release or in 3.1 coming next year. This only affects dadgets in Internet Explorer.
In the meanwhile, you can use the workaround, as I said, by changing "html" to "preview" in the dadget properties. The pdf shows the charts correctly.

Regards,
Eduardo

Offline

#20 2019-01-29 16:28:09

xpirito
Member
Registered: 2017-11-16
Posts: 12

Re: ReportServer 3.0.2.8 - IE report dadget HTML render issues

Hello. Any news on this issue? Thanks for your support.

Offline

#21 2019-02-01 08:36:12

eduardo
Administrator
Registered: 2016-11-01
Posts: 1,080
Website

Re: ReportServer 3.0.2.8 - IE report dadget HTML render issues

Hi xpirito,

this issue is currently in the development queue. I will update here when I have more information.

Regards,
Eduardo

Offline

Board footer

Powered by FluxBB